主页

///资金抄底

IF(PERIODNAME<>"日线")

{

统计:"该指标只在日线周期下有效。";

RETURN;

}

//大单净量

r:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;

//相对强弱

LC := REF(CLOSE,1);//前一日收盘价;

RSI$$1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;

RSI$$2:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;

RSI$$3:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;

相对强弱:=0.5*RSI$$1+0.31*RSI$$2+0.19*RSI$$3;

wave$$1:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),3,1);

wave$$2:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),5,1);

wave$$3:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),8,1);

短线波段:=0.5*wave$$1+0.31*wave$$2+0.19*wave$$3;

机会区:20,POINTDOT,colorred;

风险区:80,POINTDOT,colorgreen;

风险系数:0.5*相对强弱+0.5*短线波段,coloryellow;

//买入条件;

CD1:=IF(风险系数<20 AND CLOSE>OPEN AND r>0,1,0);//波段小于20,股价翻红;

CD2:=IF(风险系数<20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND r>0,1,0);//波段小于20,股价未翻红,但未创新低;

CD3:=IF(REF(风险系数,1)<20 AND 风险系数>REF(风险系数,1),1,0);//前一日波段小于20,今日转向;www.88gs.com/

SIGNALBUY=(CD1=1 OR CD2=1 OR CD3=1);

X=(SIGNALBUY AND COUNT(SIGNALBUY,3)=1);

DRAWICON(X,机会区,"buy");

///资金仓位

IF(PERIODNAME<>"日线")

{

统计:"该指标只在日线周期下有效。";

RETURN;

}

m5=0;

m10=0;

m20=0;

m30=0;

m60=0;

a2=MA(C,1);

a5=MA(C,5);

a10=MA(C,10);

a20=MA(C,20);

a30=MA(C,30);

a60=MA(C,60);

IF(a5=NULL)m5=100;

IF(a2>=a5)

{

m5=100;

IF(a2>=a10)

{

m10=0;

IF(a2>=a20)

{

m20=0;

IF(a2>=a30)

{

m30=0;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-100;

}

}

IF(a2<a30)

{

m30=-70;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-30;

}

}

}

IF(a2<a20)

{

m20=-50;

IF(a2>=a30)

{

m30=0;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-50;

}

}

IF(a2<a30)

{

M30=-20;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-30;

}

}

}

}

IF(a2<a10)

{

m10=-50;

IF(a2>=a20)

{

m20=10;

IF(a2>=a30)

{

m30=0;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-60;

}

}

IF(a2<a30)

{

m30=-30;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-30;

}

}

}

IF(a2<a20)

{

m20=-10;

IF(a2>=a30)

{

m30=0;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-40;

}

}

IF(a2<a30)

{

m30=-20;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-20;

}

}

}

}

}

IF(a2<a5)

{

m5=0;

IF(a2>=a10)

{

m10=50;

IF(a2>=a20)

{

m20=20;

IF(a2>=a30)

{

m30=10;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-80;

}

}

IF(a2<a30)

{

m30=-40;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-30;

}

}

}

IF(a2<a20)

{

M20=0;

IF(a2>=a30)

{

m30=0;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-50;

}

}

IF(a2<a30)

{

m30=-20;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-30;

}

}

}

}

IF(a2<a10)

{

m10=0;

IF(a2>=a20)

{

m20=50;

IF(a2>=a30)

{

m30=0;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-50;

}

}

IF(a2<a30)

{

m30=-20;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-30;

}

}

}

IF(a2<a20)

{

M20=0;

IF(a2>=a30)

{

m30=30;

IF(a2>=a60)

{

m60=0;

}

IF(a2<a60)

{

m60=-30;

}

}

IF(a2<a30)

{

m30=0;

IF(a2>=a60)

{

m60=10;

}

IF(a2<a60)

{

m60=0;

}

}

}

}

}

IF(a2>=a5 AND a2>=a10 AND a2>=a20 AND a2>=a30 AND a2<a60)m5=150;

IF(a2>=a5 AND a2>=a10 AND a2<a20 AND a2>=a30 AND a2<a60)m5=130;

IF(a2>=a5 AND a2>=a10 AND a2>=a20 AND a2<a30 AND a2<a60)m5=130;

IF(a2>=a5 AND a2<a10 AND a2<a30 AND a2<a60)m5=110;

IF(a2<a5 AND a2>=a10 AND a2>=a20 AND a2>=a30 AND a2<a60)m5=30;

IF(a2>=a5 AND a2>=a10 AND a2>=a20 AND a5>=a10 AND a2<a30 AND a2<a60)m5=130;

IF(a2>=a5 AND a2>=a10 AND a5>=a10 AND a2<a20 AND a2<a30 AND a2<a60)m5=120;

IF(a2>=a5 AND a2>=a10 AND a5<a10 AND a2<a20 AND a2<a30 AND a2<a60)m5=110;

IF(a2>=a5 AND a2>=a10 AND a2>=a20 AND a2>=a30 AND a2<a60 AND a5<a10 AND a10<a30)m5=130;

m=m5+m10+m20+m30+m60;

IF(m>=50){STICKLINE(m,0,m,10,1),colorred;}ELSE{STICKLINE(m,0,m,10,1),colorgreen;}