擒龙MACD:同花顺指标源码_同花顺指标公式_000001在线网_Www.000001zx.com
擒龙MACD:同花顺指标源码
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
MACD:=EMA(DIF,9),COLOR33CCFF;
DEF:2*(DIF-MACD),COLORFFFF00,LINETHICK0;
STICKLINE(DEF>=0 AND DEF>=REF(DEF,1),0,DEF,0,0),colorred;
STICKLINE(DEF>=0 AND DEF< REF(DEF,1),0,DEF,0.0,0),colorred;
STICKLINE(DEF<0 AND DEF>=REF(DEF,1),0,DEF,0.0,0),colorcyan;
STICKLINE(DEF<0 AND DEF< REF(DEF,1),0,DEF,0.0,0),colorcyan;
IF(DIF<1000,0,DRAWNULL),colorbrown;
K1:=BACKSET(DIF>REF(DIF,1),2);
强DIF:IF(K1,DIF,DRAWNULL),colorred;
K2:=BACKSET(DIF<REF(DIF,1),2);
弱DIF:IF(K2,DIF,DRAWNULL),COLORFF8B80;
K3:=BACKSET(MACD>REF(MACD,1),2);
MACD:IF(K3,MACD,DRAWNULL),colorlired;
K4:=BACKSET(MACD<REF(MACD,1),2);
MACD:IF(K4,MACD,DRAWNULL),COLORFF8B80;
底拐: DRAWLINE(DIF>=HHV(DIF,21),DIF,DIF<=LLV(DIF,21),DIF,1),colorwhite,POINTDOT;
DRAWICON(强DIF>底拐 AND REF(DIF,1)=REF(底拐,1) AND REF(DIF,2)>REF(DIF,1),0,1);
A1:=BARSLAST(REF(CROSS(DIF,MACD),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,MACD);
DRAWLINE(A1=0,MACD,底背离,MACD,0),coloryellow,LINETHICK2;
A2:=BARSLAST(REF(CROSS(MACD,DIF),1));
背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(MACD,DIF);
DRAWLINE(A2=0,MACD,顶背离,MACD,0),colorgreen,LINETHICK2;
AA1:=IF(DEF>0,1,-1);
AA2:=REF(AA1,1);
AA3:=AA1*AA2;
AA4:=BARSLAST(AA3<0);
AA5:=AA4+1;
{000001在线www.000001zx.com};