终极作品主图:同花顺指标源码_同花顺指标公式_000001在线网_Www.000001zx.com
终极作品主图:同花顺指标源码
MA5:MA(C,5),COLORFFFFFF,LINETHICK1;
MA20:MA(C,20),COLORFF80FF,LINETHICK2;
MA120:MA(C,120),colorcyan,LINETHICK2;
角5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
角20:ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416,nodraw,colorwhite;
角120:=ATAN((MA120/REF(MA120,1)-1)*100)*180/3.1416,nodraw,colorwhite;
涨幅:=(C-REF(C,1))/REF(C,1)*100;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
乖离:=ABS((MA20-MA120)/MA20*100),NODRAW,colorwhite;
涨:=IF(REF(CCI,1)<100,CCI>120,CCI>100);
跌:=IF(REF(CCI,1)>-100,CCI<-120,CCI<-100);
震荡:=涨=0 AND 跌=0;
//BOLL线
上:MA20+2*STD(CLOSE,20),COLOR0000FF,DOTLINE;
下:MA20-2*STD(CLOSE,20),COLOR00FF00,DOTLINE;
中上轨:上-(上-下)/6,COLORFFFF00,DOTLINE;
中下轨:下+(上-下)/6,COLORFFFF00,DOTLINE;
两格:=中上轨-MA20;
//用不同颜色画不同行情的K线
STICKLINE(涨=1,H,L,0,0),colorred;
STICKLINE(涨=1 AND C>=O,C,O,10,1),colorred;
STICKLINE(涨=1 AND C<O,C,O,10,0),colorred;
STICKLINE(跌=1,H,L,0,0),COLORFF6400;
STICKLINE(跌=1 AND C>=O,C,O,10,1),COLORFF6400;
STICKLINE(跌=1 AND C<O,C,O,10,0),COLORFF6400;
STICKLINE(震荡=1,H,L,0,0),coloryellow;
STICKLINE(震荡=1 AND C>=O,C,O,10,1),coloryellow;
STICKLINE(震荡=1 AND C<O,C,O,10,0),coloryellow;
//不同周期K线界面显示
IF(PERIODNAME<>"月线")
IF(PERIODNAME<>"周线")
IF(PERIODNAME<>"日线")
IF(PERIODNAME<>"60分钟")
{
BT:=(L<=中下轨 AND 跌=0 AND LLV(L,3)>LLV(L,22) AND O-C<两格) OR (L<=下 AND 跌 AND LLV(L,3)>LLV(L,22) AND O-C<两格);
ST:=(H>=中上轨 AND 涨=0 AND HHV(H,3)<HHV(H,22) AND C-O<两格) OR (H>=上 AND 涨 AND HHV(H,3)<HHV(H,22) AND C-O<两格);
DRAWICON(BT,L,1);
DRAWICON(ST,H,2);
RETURN;
}
BX:=(L<=中下轨 AND 跌=0 AND LLV(L,3)>LLV(L,20) AND O-C<两格) OR (L<=下 AND 跌 AND LLV(L,3)>LLV(L,20) AND O-C<两格);
SX:=(H>=中上轨 AND 涨=0 AND HHV(H,3)<HHV(H,20) AND C-O<两格) OR (H>=上 AND 涨 AND HHV(H,3)<HHV(H,20) AND C-O<两格);
DRAWICON(BX,L,1);
DRAWICON(SX,H,2);
低吸:=(涨 AND L<上 AND HHV(CCI,3)=HHV(CCI,8)) OR (涨 AND L<中上轨) OR (震荡 AND C>MA20 AND 角20>IF(C>1000,8,20) AND L<=MA20+(上-下)/8) OR (角20>IF(C>1000,0,8) AND L<MA20-(上-下)/8) OR BX;
高抛:=(跌 AND H>下 AND LLV(CCI,3)=LLV(CCI,8)) OR (跌 AND H>中下轨) OR (震荡 AND C<MA20 AND 角20<IF(C>1000,-8,-20) AND H>=MA20-(上-下)/8) OR (角20<IF(C>1000,0,-8) AND H>MA20+(上-下)/8) OR SX;
观望:=低吸=0 AND 高抛=0;
DRAWTEXT_FIX(ISLASTBAR,0.5,0.05,0,'<使用说明> -->'),colorred;
DRAWTEXT_FIX(ISLASTBAR,0.57,0.05,0,'红色上涨,蓝色下跌,黄色震荡'),colorcyan;
DRAWTEXT_FIX(ISLASTBAR,0.5,0.1,0,'<使用说明> -->'),colorred;
DRAWTEXT_FIX(ISLASTBAR,0.57,0.1,0,'当买点信号出现时,先用大一级别周期确认处于低吸区域,否则买点信号真实性偏弱)'),colorcyan;
DRAWTEXT_FIX(ISLASTBAR AND BX,0.5,0.2,0,'<买点信号介入价格> -->'),colorred;
DRAWNUMBER_FIX(ISLASTBAR AND BX,0.6,0.2,0,TOSTRING(IF(跌,下,中下轨),2)),colorcyan;
DRAWTEXT_FIX(ISLASTBAR AND BX,0.62,0.2,0,'下方或附近'),colorred;
DRAWTEXT_FIX(ISLASTBAR,0.5,0.15,0,"当前行情 -->"),colorred;
DRAWTEXT_FIX(ISLASTBAR AND 低吸,0.57,0.15,0,"当前行情处于低吸区"),colormagenta;
DRAWTEXT_FIX(ISLASTBAR AND 高抛,0.57,0.15,0,"当前行情处于高抛区"),colormagenta;
DRAWTEXT_FIX(ISLASTBAR AND 观望,0.57,0.15,0,"当前行情处于观望区,等待低吸或高抛"),colormagenta;
{000001在线www.000001zx.com};
五矿证券通达信合一版 新浪通达信版英大证券香港中州证券中原证券集成版太平洋证券通达信合一版世纪证券通达信版江海证券通达信合一版联讯证券通达信至尊版国开证券合一版国联证券合一版红塔证券安信证券通达信开源证券超强版国金证券太阳至强版东莞证券财富通版山西证券汇通启富银泰证券通达信合一版新时代证券新时代通达信灵动密码版华创证券通达信版华宝证券通达信版网上交易至富版天风证券通达信合一版金管家国盛证券通达信版金元证券通达信合一版中航证券至诚版日信证券通达信超强版众成证券网上交易超强版首创证券超强合一版万联证券通达信恒泰证券金玉满堂通达信上海华信证券通达信版民生证券通达信合一版国都证券集成版长城国瑞证券金鼓盈通万和证券通达信专业版华融证券通达信华鑫证券鑫智汇投资理财系统通达信爱建证券超强版财通证券财路通大同证券V6合一版通达信金融终端免费版v7版长城证券烽火版兴业证券通达信长江证券金长江财智版东北证券通达信中国银河证券海王星版中信建投证券网上交易极速版国信证券金太阳版国泰君安锐智版中银国际证券中泰证券融易汇信达证券通达信专业版财富证券财富快车版国海证券通达信行情交易整合版东吴证券合一版方正证券泉友通金鼎版中信证券至信全能版申万宏源证券申银万国旗舰版东兴证券超强版东方证券东海证券超强版新一代华林证券华龙证券超强版宏信证券通达信合一版华安证券达信德邦证券通达信版中国民族证券网上直通车渤海证券新合一版大通证券网上交易神通版第一创业证券通达信集成版海通证券彩虹投资通达信版国元证券国元领航华泰证券网上交易系统通达信版中投证券合一版光大证券金阳光卓越版广发证券金管家至强版中信万通至信版上海证券行情卓越版