尖顶针主图指标:通达信公式源码_通达信指标公式_000001在线网_Www.000001zx.com
尖顶针主图指标:通达信公式源码
VAR1:=1;
VAR2:=REF(CLOSE-OPEN, 2);
VAR3:=REF(CLOSE, 1);
VAR4:=REF(CLOSE, 2);
VAR5:=REF(CLOSE, 3);
VAR6:=REF(CLOSE, 4);
VAR7:=MAX(MAX(MAX(CLOSE, VAR3), VAR4), VAR5);
VAR8:=MIN(MIN(MIN(CLOSE, VAR3), VAR4), VAR5);
{红持股:STICKLINE(CLOSE=VAR7 AND (VAR3>=VAR4 OR VAR3>=VAR5) OR VAR3=VAR7 AND (VAR4=VAR8 OR VAR5=VAR8) AND CLOSE>=VAR4 OR VAR4=VAR7 AND VAR5=VAR8 AND CLOSE>=VAR3 OR VAR5=VAR7 AND CLOSE>=VAR3 AND CLOSE>=VAR4, VAR3, CLOSE, 5, 1), COLORRED;}
{品红变盘:STICKLINE(CLOSE=VAR7 AND VAR3=VAR8, VAR4, CLOSE, 5, 1), COLORMAGENTA;}
{黄下跌:STICKLINE(CLOSE=VAR8 AND (VAR3<VAR4 OR VAR3<VAR5) OR VAR3=VAR8 AND (VAR4=VAR7 OR VAR5=VAR7) AND CLOSE<VAR4 OR VAR4=VAR8 AND VAR5=VAR7 AND CLOSE<VAR3 OR VAR5=VAR8 AND CLOSE<VAR3 AND CLOSE<VAR4, VAR3, CLOSE, 5, 0), COLORYELLOW;}
{绿买:STICKLINE(VAR3=VAR7 AND CLOSE=VAR8, VAR4, CLOSE, 5, 0), COLORGREEN;}
{STICKLINE(VAR3=VAR8 AND CLOSE>=VAR4 OR (VAR4=VAR8 AND VAR3<=VAR5 OR VAR5=VAR8 AND VAR3<=VAR4) AND VAR4<VAR6 AND CLOSE>=VAR3, VAR3, VAR4, 5, 0), COLORGREEN;}
蓝卖:STICKLINE(VAR3=VAR7 AND CLOSE<VAR4 OR (VAR4=VAR7 AND VAR3>VAR5 OR VAR5=VAR7 AND VAR3>VAR4) AND VAR4>=VAR6 AND CLOSE<VAR3, VAR3, VAR4, 5, 1), COLORBLUE;
VAR9:=SAR(5, 1, 5);
VAR10:=EMA(CLOSE, 30);
VAR11:=IF(CLOSE>450, 8, IF(CLOSE>=20 AND CLOSE<150, 0.200, IF(CLOSE<20 AND CLOSE>=10, 0.070, IF(CLOSE<10, 0.030, 0.070))));
{变色龙:STICKLINE(CLOSE>VAR9, VAR10, VAR10+VAR11, 6, 0), COLORMAGENTA;}
STICKLINE(CLOSE<VAR9, VAR10, VAR10-VAR11, 6, 0), COLORCYAN;
STICKLINE(CROSS(CLOSE, VAR9), VAR10, VAR10-VAR11, 6, 0);
STICKLINE(CROSS(VAR9, CLOSE), VAR10, VAR10+VAR11, 6, 0), COLORFF0066;
STICKLINE(RANGE(DAY, 6, 9) OR RANGE(DAY, 27, 30), VAR10+0.010, VAR10-0.010, 6, 0), COLORYELLOW;
VAR22:=MA(LLV(CLOSE,9)*1.1,14)*1;
VAR33:=MA(HHV(CLOSE,26)*0.9,14)*1;
VAR55:=EMA((HIGH+LOW+CLOSE)/3,3);
VARB:=AMOUNT/(100*VOL);
VARC:=MA(VARB,34);
VARD:=MA(CLOSE,26);
通道: (VARD+VARC)/2, POINTDOT, COLORYELLOW;
阻力: VARD+2*STD(CLOSE,34),LINETHICK2 , COLORGREEN;
支持: (VARD-2*STD(CLOSE,26)),LINETHICK2 , COLORGREEN;
VARE:=MA(WINNER(CLOSE),34)*100;
警: DRAWTEXT(VARE>60 AND HIGH>阻力,HIGH,'★警'), COLORYELLOW;
突破:DRAWTEXT(VARE<15 AND CROSS(VAR55,通道),LOW,'★突破'), COLORAAAAAA;
MA5:MA(C,5);
BB5:=MA5-REF(MA5,1);
MA10:MA(C,10);
BB10:=MA10-REF(MA10,1);
MA20:=EMA(C,20);
A1:=FILTER(MA5>REF(MA5,1)AND MA10>REF(MA10,1)AND MA20>REF(MA20,1)AND MA5<MA10,5);
A2:=(2*C+H+L+O)/5;
A3:=LLV(L,5);
A4:=HHV(H,4);
A5:=EMA((A2-A3)/(A4-A3)*100,4);
A6:=EMA(0.667*REF(A5,1)+0.333*A5,2);
A7:=EMA(A2,13)-EMA(A2,34);
A8:=EMA(A7,5); A9:=(-2)*(A7-A8)*3.8;
DRAWTEXT(CROSS(A5,A6)AND A1<40,L-0.08,' 买'),COLORYELLOW;
DRAWTEXT(CROSS(A9,MA(A9,3))AND(A7>A8),H+0.08,' 卖'),COLORGREEN;
{000001在线www.000001zx.com};
五矿证券通达信合一版 新浪通达信版英大证券香港中州证券中原证券集成版太平洋证券通达信合一版世纪证券通达信版江海证券通达信合一版联讯证券通达信至尊版国开证券合一版国联证券合一版红塔证券安信证券通达信开源证券超强版国金证券太阳至强版东莞证券财富通版山西证券汇通启富银泰证券通达信合一版新时代证券新时代通达信灵动密码版华创证券通达信版华宝证券通达信版网上交易至富版天风证券通达信合一版金管家国盛证券通达信版金元证券通达信合一版中航证券至诚版日信证券通达信超强版众成证券网上交易超强版首创证券超强合一版万联证券通达信恒泰证券金玉满堂通达信上海华信证券通达信版民生证券通达信合一版国都证券集成版长城国瑞证券金鼓盈通万和证券通达信专业版华融证券通达信华鑫证券鑫智汇投资理财系统通达信爱建证券超强版财通证券财路通大同证券V6合一版通达信金融终端免费版v7版长城证券烽火版兴业证券通达信长江证券金长江财智版东北证券通达信中国银河证券海王星版中信建投证券网上交易极速版国信证券金太阳版国泰君安锐智版中银国际证券中泰证券融易汇信达证券通达信专业版财富证券财富快车版国海证券通达信行情交易整合版东吴证券合一版方正证券泉友通金鼎版中信证券至信全能版申万宏源证券申银万国旗舰版东兴证券超强版东方证券东海证券超强版新一代华林证券华龙证券超强版宏信证券通达信合一版华安证券达信德邦证券通达信版中国民族证券网上直通车渤海证券新合一版大通证券网上交易神通版第一创业证券通达信集成版海通证券彩虹投资通达信版国元证券国元领航华泰证券网上交易系统通达信版中投证券合一版光大证券金阳光卓越版广发证券金管家至强版中信万通至信版上海证券行情卓越版