DMI趋势副图指标:飞狐公式_经典股票指标_000001在线网_Www.000001zx.com
DMI趋势副图指标:飞狐公式
ATRA := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),6,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),6,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),6,1);
PDI:= DMP*100/ATRA;
MDI:= DMM*100/ATRA;
ADX: SMA(ABS(MDI-PDI)/(MDI+PDI)*100,6,1),LINETHICK2;
趋势:FILLRGN((MDI-PDI)/(MDI+PDI)<0,10,ADX),COLOR8899DD;跌趋势:FILLRGN((MDI-PDI)/(MDI+PDI)>=0,10,ADX),COLORDD9988;对比线:=(ADX+REF(ADX,6))/2;STICKLINE(交叉函数(ADX,30),ADX,30,10,0),
 Color00FFFF,LINETHICK5;
80,ColorFFFFFF,LINEDOT;
50,LINEDOT;
20,LINEDOT;{Www.000001zx.com};
ww1:=SMA(((CLOSE-LLV(CLOSE,10))/(HHV(HIGH,10)-LLV(LOW,10))),3,1);
ww2:=SMA(((ww1-LLV(ww1,3))/(HHV(ww1,3)-LLV(ww1,3))),3,1)*100;
zz:=SMA(((vol' target='_blank'>VOL-LLV(vol' target='_blank'>VOL,10))/(HHV(vol' target='_blank'>VOL,10)-LLV(vol' target='_blank'>VOL,10))),3,1);
zz1:=SMA(((zz-LLV(zz,3))/(HHV(zz,3)-LLV(zz,3))),3,1)*100;
快线:=EMA(ww2,1),COLORBLUE,LINETHICK2;
慢线:=EMA(快线,2),COLORGREEN,LINETHICK2;
量快:=EMA(zz1,1)COLORWHITE,LINETHICK2;
量慢:=EMA(量快,2),COLORWHITE,LINETHICK2;
AA1:=移动平均(((收盘价-最低值(收盘价,13))/(最高值(最高价,13)-最低值(最低价,13))),3,1);
价线:=移动平均(((AA1-最低值(AA1,4))/(最高值(AA1,4)-最低值(AA1,4))),3,1)*100;
周线:MA(价线,5),COLORMAGENTA,LINETHICK0;{Www.000001zx.com};BB1:=移动平均(((vol-最低值(vol,13))/(最高值(vol,13)-最低值(vol,13))),3,1);量线:=移动平均(((BB1-最低值(BB1,4))/(最高值(BB1,4)-最低值(BB1,4))),3,1)*100;
周量:MA(量线,5),COLORyellow,LINETHICK0;
月线:=MA(价线,22),COLORRED,LINEDOT,LINETHICK0;
月量:=MA(量线,22),COLORyellow,LINEDOT,LINETHICK0;
快线2:=EMA(周线,1),COLORBLUE,LINETHICK2;
慢线2:=EMA(快线2,2),COLORGREEN,LINETHICK2;
量快2:=EMA(周量,1)LINEDOT;{Www.000001zx.com};
量慢2:=EMA(量快2,2),COLORWHITE,LINETHICK2;
DRAWICON(CROSS(快线2,慢线2),慢线2,10);
DRAWICON(CROSS(慢线2,快线2),快线2,11);
DRAWICON(CROSS(量快2,量慢2),量慢2,10);
DRAWICON(CROSS(量慢2,量快2),量快2,11);
PARTLINE(周线>=REF(周线,1),周线),COLORMAGENTA,LINEDOT,LINETHICK2;
PARTLINE(周线>=REF(周线,1) AND 月线>=REF(月线,1),周线),COLORRED,LINEDOT,LINETHICK2;
PARTLINE(周线<REF(周线,1),周线),COLORgreen,LINEDOT,LINETHICK1;
PARTLINE(周量>=REF(周量,1),周量),COLORyellow,LINEDOT,LINETHICK2;
PARTLINE(周量<REF(周量,1),周量),COLORgreen,LINEDOT,LINETHICK1;
DRAWTEXT(FILTER(快线>=95 AND 慢线>=95 AND 周线>=90 OR 周量>=90,5),85,'减'),COLORWHITE,LINETHICK2;
看色块→:FILLRGN(1,30,31),COLORRED;{000001在线www.000001zx.com};