涨跌家数+价位MACD:通达信指标公式_经典股票指标_000001在线网_Www.000001zx.com
涨跌家数+价位MACD:通达信指标公式
N:=5;M:=6;
UP:=( C > O OR C > REF(C,1)) AND V > REF(V,1);
AA:=COUNT(UP,3)=3;
BB:=LLV(L,5)=LLV(L,120);
CC:=C > MA(C,3);
LLT:=AA AND BB AND CC;
V1:=LLV(LOW,10);
V2:=HHV(H,25);
短线卖出:3.2,DOTLINE;
高位卖出:3.5,DOTLINE;
价位线:=EMA((C-V1)/(V2-V1)*4,4);
DIFF:=MA(价位线,N),COLORYELLOW;
DEA:=EMA(DIFF,M);
MACD:=(DIFF-DEA)*2,LINETHICK0;{Www.000001zx.com};
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1.5,0),COLOR0000F2;
STICKLINE(MACD>=0 AND MACD<REF(MACD,1),0,MACD,1.5,1),COLOR0000F2;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,1.5,0),COLOR008000;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,1.5,1),COLOR008000;
IF(1,DIFF,DRAWNULL),COLORCYAN;{Www.000001zx.com};
IF(DIFF>=REF(DIFF,1),DIFF,DRAWNULL),COLORFF00FF,LINETHICK2;
IF(1,DEA,DRAWNULL),COLOR1AFFFF;
涨家数:INDEXADV,NODRAW,COLORLIMAGENTA ;
跌家数:INDEXDEC,NODRAW,COLORGREEN;

{说明:本指标可用于通达信};

{000001在线www.000001zx.com};