全方位成交量:飞狐指标源码公式_飞狐指标公式_000001在线网_Www.000001zx.com
全方位成交量:飞狐指标源码公式
VOL,VOLSTICK;
预测额:=IF(DATE<>CURRENTDATE OR OPENMINUTES(CURRENTTIME)=1,AMOUNT,(AMOUNT/OPENMINUTES(CURRENTTIME))*240), LINETHICK;
n:=20;
SAT:=IF((预测额/CLOSE)/(HHV(预测额,N)/HHV(CLOSE,N))*100>100,100,(预测额/CLOSE)/(HHV(预测额,N)/HHV(CLOSE,N))*100);
预测量:=IF(DATE<>CURRENTDATE OR OPENMINUTES(CURRENTTIME)=1,VOL,(VOL/OPENMINUTES(CURRENTTIME))*240), LINETHICK;
量:=VOL;
V0001:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,V0001*(HIGH-LOW),IF(CLOSE<OPEN,V0001*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),Color6d0076,POINTDOT,LINETHICK0,PRECISION0,COLORRED;
主卖:IF(CLOSE>OPEN,0-V0001*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-V0001*(HIGH-LOW),0-VOL/2)),ColorFFD1BE,POINTDOT,LINETHICK0,PRECISION0;
净买:主买+主卖,COLORMAGENTA,LINETHICK0,PRECISION0;
换手率:VOL/CAPITAL*100,ColorD19857;
hs:=换手率;
量比:IF(BARPOS=DATACOUNT,DYNAINFO(17),VOL/REF(MA(VOL,5),1)),LINETHICK0,COLORYELLOW,PRECISION2;
A:=MA(换手率,2);
X:=LLV(A,20),linethick;
X1:=(A-LLV(A,20))=0;
换手最小:=IF(ALL (A>0,5) AND FILTERX(X1,5),X1,0),COLORRED;
小天:=BARSLAST(换手最小),LINETHICK,color008888;
X2:=HHV(A,20);
X3:=(A-X2)=0;
换手最大:=IF(ALL(REF(A,1)<X2,5) AND FILTERX(X3,5),1,0),COLORGREEN;
STICKLINE(CLOSE<=REF(CLOSE,1) , VOL,0,8,1),ColorFFFF80,LINETHICK1;
STICKLINE(CLOSE>REF(CLOSE,1), VOL,0,8,1),COLORRED,LINETHICK1;
stickline(换手率<1 ,V,0,2.8,0),ColorFF4D91,;
stickline(换手率>1 ,V,0,2.8,0),Color00FF00;
stickline(换手率>3 ,V,0,2.8,0),coloryellow,ColorFFFFFF;
stickline(换手率>5,V,0,2.8,0),color0099ff,COLORMAGENTA;
stickline(换手率>10,V,0,2.8,0),Color0000FF,COLORRED;
DRAWTEXTEX(V,1,0,0,'换手率小于1:紫\\'+NUMTOSTR(SELFDATA('换手率小于1'),0)),ColorFF158A;
DRAWTEXTEX(V,1,110,0,'换手率大于1:绿\\'+NUMTOSTR(SELFDATA('换手率大于1'),0)),COLORGREEN;;
DRAWTEXTEX(V,1,220,0,'换手率大于3:白\\'+NUMTOSTR(SELFDATA('换手率大于3'),0)),ColorFFFFFF;
DRAWTEXTEX(V,1,330,0,'换手率大于5:粉\\'+NUMTOSTR(SELFDATA('换手率大于5'),0)),COLORMAGENTA;
DRAWTEXTEX(V,1,440,0,'换手率大于10:红\\'+NUMTOSTR(SELFDATA('换手率大于10'),0)),COLORRED;
{线形}
l13:=LLV(MA(VOL,5),13),COLORBROWN,LINETHICK2;
m5:MA(V,5),COLORYELLOW,PRECISION0;
m13:=MA(V,13),COLORCYAN,PRECISION0;
m34:MA(V,34),COLORMAGENTA,PRECISION0;
V2:IF(BARSTATUS=2,VOL*240/MINUTE/REF(VOL,1)-1,VOL/REF(VOL,1)-1),COLORRED;
STICKLINE(V2>=1,0,VOL,8,0),COLORYELLOW,;
F:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
今小昨:=IF(CLOSE<REF(OPEN,1) AND F<0,1,0);
Sa1:=今小昨;
今小前:=IF(CLOSE<REF(OPEN,2) AND F<0,1,0),LINETHICK0;
Sa2:=今小前;
svol:=INTPART(SUM(VOL,0)/CAPITAL);
tj0:=svol>REF(svol,1) or BARSSINCE(CLOSE)=0;
S1:=BARSLAST(tj0)+1,PRECISION,COLORWHITE;//时间1
tj2:=S1<REF(S1,1);//取点
S2:=IF(tj2,REF(S1,1)+1,S1),PRECISION,COLORMAGENTA;//时间2
S3:=SUM(tj2,0),COLORMAGENTA;
阶段总额(万元):=SUM(AMOUNT/10000,S2)*100,PRECISION,LINETHICK,Color008BFA;//换手100%AMOUNT
阶段总量(手):=SUM(VOL,S2)*100,PRECISION,LINETHICK,COLORCYAN;//换手100%VOL
阶段成本(元):=(阶段总额(万元)/(阶段总量(手)/100)),LINETHICK,PRECISION2,COLORRED;
DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,'■阶段平均成本:'+NUMTOSTR(阶段成本(元)[SYSPARAM(1)],2)+'(元)'),align4,ColorFFE0FF,pxdn30,shift;
{取点}
Zk1:=STKINDI('' ,'kdj.k',0,7);
Zd2:=STKINDI('' ,'kdj.d',0,7);
ZF1:=STKINDI('' ,'macd.diff',0,7);
ZA2:=STKINDI('' ,'macd.dea',0,7);
{建仓统计}
JCD:=FILTER(CROSS(Zk1,Zd2) and Zd2<30,13);{周KD金叉位置}
取点:=BARSLAST(JCD);
吸筹区:=IF(取点>0 and 取点<61,取点,0);
ZS1:=吸筹区;
ZS2:=吸筹区+1;
ZS3:=换手率/5;{庄家筹码估算}
ZSA:=IF(ZS1>0,SUM((ZS3),吸筹区+1),0);{统计庄家筹码}
{控制画线高度}
n1:=SYSPARAM(3);
nn:=n1-SYSPARAM(2)+1;
hh:=HHV(VOL,nn);
ll:=LLV(VOL,nn);
最高:=hh[n1];
最低:=ll[n1];
中:=最低+(最高-最低)*0.5;
PARTLINE(RANGE(BARPOS,SYSPARAM(2),SYSPARAM(1)+1)&&ZS1>0,中),COLORCYAN;//建仓横线
VERTLINE(JCD),LINEDOT,COLORGREEN;//建仓点竖线
{可移动变化数字}
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(1)&&SYSPARAM(1)>ZS1,中*2.5,' ■主力建仓天数:'+NUMTOSTR(ZS1[SYSPARAM(1)],0)+'(天)'),PXDN1,align2,COLORYELLOW;
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(1)&&SYSPARAM(1)>ZS1,中*2.5,' \n■估算主力筹码:'+NUMTOSTR(ZSA[SYSPARAM(1)],2)+'%'),PXDN10,align2,COLORMAGENTA;
{000001在线www.000001zx.com};
浏览器下载五矿证券通达信合一版 新浪通达信版英大证券香港中州证券中原证券集成版太平洋证券通达信合一版世纪证券通达信版江海证券通达信合一版联讯证券通达信至尊版国开证券合一版国联证券合一版红塔证券安信证券通达信开源证券超强版国金证券太阳至强版东莞证券财富通版山西证券汇通启富银泰证券通达信合一版新时代证券新时代通达信灵动密码版华创证券通达信版华宝证券通达信版网上交易至富版天风证券通达信合一版金管家国盛证券通达信版金元证券通达信合一版中航证券至诚版日信证券通达信超强版众成证券网上交易超强版首创证券超强合一版万联证券通达信恒泰证券金玉满堂通达信上海华信证券通达信版民生证券通达信合一版国都证券集成版长城国瑞证券金鼓盈通万和证券通达信专业版华融证券通达信华鑫证券鑫智汇投资理财系统通达信爱建证券超强版财通证券财路通大同证券V6合一版通达信金融终端免费版v7版长城证券烽火版兴业证券通达信长江证券金长江财智版东北证券通达信中国银河证券海王星版中信建投证券网上交易极速版国信证券金太阳版国泰君安锐智版中银国际证券中泰证券融易汇信达证券通达信专业版财富证券财富快车版国海证券通达信行情交易整合版东吴证券合一版方正证券泉友通金鼎版中信证券至信全能版申万宏源证券申银万国旗舰版东兴证券超强版东方证券东海证券超强版新一代华林证券华龙证券超强版宏信证券通达信合一版华安证券达信德邦证券通达信版中国民族证券网上直通车渤海证券新合一版大通证券网上交易神通版第一创业证券通达信集成版海通证券彩虹投资通达信版国元证券国元领航华泰证券网上交易系统通达信版中投证券合一版光大证券金阳光卓越版广发证券金管家至强版中信万通至信版上海证券行情卓越版